Page 1 of 1

Linux: no sound - solution

Posted: Sat Jul 16, 2016 12:43 pm
by sema
I have just spotted an interesting problem on my Ubuntu:
the default MIDI-Out port is a dummy Midi Through Port-0 that produces no sound.
To see the list of ports, run aconnect -o

You can disable the dummy port by running sudo rmmod snd_seq_dummy
or/and filter it out in JavaScript with a RegEx:

Code: Select all

var out = JZZ().openMidiOut(/^((?!Midi Through).)*$/i);