Page 1 of 1

Microsoft GS Wavetable Synth / Windows 8

Posted: Mon Mar 16, 2015 6:21 am
by James_Ingram
I'm using Jazz in a Web MIDI app in Firefox, and it is not finding the Microsoft GS Wavetable Synth on Windows 8.
The Synth is being found okay, and is working fine, in Windows Media Player.

Faq #11, at the bottom of the page, at
says that the MS GS Synth was moved, in Windows 8, from being at device position 1 to device position 0.

Could it be that Jazz is looking for the Synth at the wrong position in Windows 8?

All the best,

Re: Microsoft GS Wavetable Synth / Windows 8

Posted: Mon Mar 16, 2015 5:48 pm
by sema
It works fine on my Windows 8 machine, but thank you for the hint.
What do you have installed on your machine?

Re: Microsoft GS Wavetable Synth / Windows 8

Posted: Tue Mar 17, 2015 5:30 am
by James_Ingram
Edit: See my next post! This one is obsolete.

Its very odd that its working on your Windows 8 machine! :shock:

There seems to be something wrong with mine. Maybe a problem in the registry?
If you know of a critical registry setting that may be corrupt, perhaps you could let me know, and I'll have a look.

Further information:
I have another machine running Windows 7. Both Chrome and Firefox(+Jazz) are working perfectly there.
The Chrome Web MIDI implementation is not finding the MS GS Synth either on Windows 8.

Windows Media Player is playing MIDI files on Windows 8, so the MS GS Synth must be there somewhere.

I just checked my plugin settings for both Firefox and Chrome. Discovered something I wasn't expecting:
Jazz was both installed and enabled on Windows 8 Chrome.
I was expecting it not to appear at all (as in the Windows 7 Chrome plugins).
I have now disabled Jazz in Windows 8 Chrome, since I'm using Chrome's Web MIDI flag, but I still have no access to the MS GS Synth, in either Chrome or Firefox(=Jazz), in Windows 8.

Installed programs:
1 Coolsoft's VirtualMIDISynth:
Jazz is finding this on both my Windows 7 and Windows 8 machines.
Jazz is findng the MS GS Synth on Windows 7, but not on Windows 8.
I have tried uninstalling the VirtualMIDISynth on Windows 8, to see if there was some kind of conflict, but that does not help. (Jazz then returns an empty output device list.)
I'd be surprised if Coolsoft failed to restore some registry setting when uninstalling the VirtualMIDISynth, but stranger things have happened... The VirtualMIDISynth seems to be very reliable and well programmed.

2. Visual Studio Community Edition 2013:
Visual Studio digs deep into the system, but could a Microsoft product really be the source of the problem?

There are a few other programs installed, but I don't think any of them would tinker with the (MIDI) devices.

Its very odd. The annoying thing is that its not a particularly important problem for me. Maybe it will just go away when Windows 10 arrives. But I'd prefer knowing what's going on anyway!

All the best,

Re: Microsoft GS Wavetable Synth / Windows 8

Posted: Tue Mar 17, 2015 2:57 pm
by James_Ingram
Hi sema,

I had a lengthy correspondence with Tom White (MIDI Manufacturers Association) about this problem before I contacted you about it.
He now writes:
> James,

> I asked a web app developer at Yamaha to check your problem with
> Windows 8, and he was able to get the MS GS Synth to display in
> his Web app... but he also observed that it would not display if
> another app accessed the device first... maybe you can check if
> that was the problem?

> - TW

(Yamaha web app developer)
> > I have investigated a little bit more with basic Web MIDI App on
> > Windows 8.1 (Sorry I do not have 8.0 PC around).
> >
> > For (a) =
> >
> > 1. Access "(a)", then Run DAW: "MS GS Synth" comes to the List
> >
> > 2. Run DAW, then Access "(a)": "MS GS Synth" DOES NOT come to the List
> >
> > The case is that the "MS GS Synth" does not list when the DAW (or any
> > other applications which use MIDI devices) is running before the browser
> > starts.
> >
> > It looks Windows is doing exclusive control, so MIDI devices, which
> > is grabbed by application, are locked to use from other application.

I'll investigate in the morning.
Will let you know how I get on, hopefully with the answer.


Re: Microsoft GS Wavetable Synth / Windows 8

Posted: Wed Mar 18, 2015 4:15 am
by James_Ingram
The Yamaha test app works as expected, but I haven't been able to find the process that is causing the problem.

I don't want to spend too much time digging about in my Windows 8.1 setup, so I've now passed the problem on to Microsoft.

I'll let you (all) know when/if I get an answer that solves the problem. :-)


Re: Microsoft GS Wavetable Synth / Windows 8

Posted: Mon Mar 30, 2015 12:53 pm
by James_Ingram
Problem solved.
The solution was to repair some corrupt system files, as described in a reply from Microsoft at ... 7721183831