Windows 8 connectivity issues

Low level MIDI support via Javascript

Windows 8 connectivity issues

Postby james.baxter » Mon Oct 21, 2013 12:54 am

I've encountered a few connectivity issues with Windows 8.

If the USB device is disconnected while my app is open, Jazz does not receive notification of the disconnect. Replugging the device does nothing after this point.
If the app is opened before the USB device is connected, Jazz does not receive notification of the connection.

At the moment I'm using a popup warning to alert Windows 8 users of these issues. I'd love to hear if anyone else is having the same problems!
james.baxter
 
Posts: 2
Joined: Wed Oct 16, 2013 11:17 pm

Re: Windows 8 connectivity issues

Postby sema » Mon Oct 21, 2013 8:38 am

Well, there are things that are hard to control from the software - like unplugging USB device or turning power off.
You can probably write a timer event function that periodically checks MIDI devices availability.
sema
Site Admin
 
Posts: 303
Joined: Mon Oct 17, 2011 7:28 pm

Re: Windows 8 connectivity issues

Postby james.baxter » Thu Oct 31, 2013 12:19 am

Indeed! I poll every 1 second to check for the arrival/removal of new devices. Herein lies the problem: on Windows 8, the function that returns the number of connected devices (I can't remember what it is, off the top of my head) returns an incorrect number after device connection/removal; it continues to return the number of devices that were connected at program startup.

Have you seen this issue on Windows 8?
james.baxter
 
Posts: 2
Joined: Wed Oct 16, 2013 11:17 pm

Re: Windows 8 connectivity issues

Postby sema » Sun Nov 16, 2014 6:46 pm

Very strange indeed. I'm seeing the same issue on Windows 8 even with the new version of the plugin.
The problem must be somewhere in Windows multimedia stack.
Will update if I find anything out.
sema
Site Admin
 
Posts: 303
Joined: Mon Oct 17, 2011 7:28 pm

Re: Windows 8 connectivity issues

Postby sema » Mon Nov 17, 2014 2:56 pm

After spending some time debugging, I've just found out that I had an old version of the plugin on my Windows 8 machine :)

Yes it works now!
sema
Site Admin
 
Posts: 303
Joined: Mon Oct 17, 2011 7:28 pm


Return to Jazz-Plugin

Who is online

Users browsing this forum: No registered users and 1 guest

cron