Can't start Jazz midi in a raspberry

Low level MIDI support for Node.js

Can't start Jazz midi in a raspberry

Postby autotel » Fri May 05, 2017 9:50 pm

I am not very experienced in linux in general. I am developing an app targeted for raspberry, that would benefit of jazz-midi.
When I try to run the node module, I get the following error
Code: Select all
module.js:471
    throw err;
    ^

Error: Cannot find module './bin/6_9/'
    at Function.Module._resolveFilename (module.js:469:15)
    at Function.Module._load (module.js:417:25)
    at Module.require (module.js:497:17)
    at require (internal/module.js:20:19)
    at Object.<anonymous> (/home/pi/repositories/node-patternplatform/node_modules/jazz-midi/index.js:14:16)
    at Module._compile (module.js:570:32)
    at Object.Module._extensions..js (module.js:579:10)
    at Module.load (module.js:487:32)
    at tryModuleLoad (module.js:446:12)
    at Function.Module._load (module.js:438:3)

running jazz-midi/test.js outputs the same error.

I unistalled jazz-midi and reinstalled it again, to be able to show you te installation output:

Code: Select all
 $ npm install jazz-midi

> speaker@0.3.0 install /home/pi/repositories/node-patternplatform/node_modules/speaker
> node-gyp rebuild

make: Entering directory '/home/pi/repositories/node-patternplatform/node_modules/speaker/build'
  CC(target) Release/obj.target/output/deps/mpg123/src/output/alsa.o
../deps/mpg123/src/output/alsa.c:19:28: fatal error: alsa/asoundlib.h: No such file or directory
 #include <alsa/asoundlib.h>
                            ^
compilation terminated.
deps/mpg123/output.target.mk:107: recipe for target 'Release/obj.target/output/deps/mpg123/src/output/alsa.o' failed
make: *** [Release/obj.target/output/deps/mpg123/src/output/alsa.o] Error 1
make: Leaving directory '/home/pi/repositories/node-patternplatform/node_modules/speaker/build'
gyp ERR! build error
gyp ERR! stack Error: `make` failed with exit code: 2
gyp ERR! stack     at ChildProcess.onExit (/usr/lib/node_modules/npm/node_modules/node-gyp/lib/build.js:276:23)
gyp ERR! stack     at emitTwo (events.js:106:13)
gyp ERR! stack     at ChildProcess.emit (events.js:191:7)
gyp ERR! stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:215:12)
gyp ERR! System Linux 4.4.50-v7+
gyp ERR! command "/usr/bin/nodejs" "/usr/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
gyp ERR! cwd /home/pi/repositories/node-patternplatform/node_modules/speaker
gyp ERR! node -v v6.10.2
gyp ERR! node-gyp -v v3.4.0
gyp ERR! not ok
pattern-platform@1.0.0 /home/pi/repositories/node-patternplatform
└── jazz-midi@1.5.4

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: speaker@0.3.0 (node_modules/speaker):
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: speaker@0.3.0 install: `node-gyp rebuild`
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: Exit status 1

Perhaps from your guidance I could write a basic tutorial to make this install for other inexperienced raspberry users.
autotel
 
Posts: 2
Joined: Fri May 05, 2017 12:28 am

Re: Can't start Jazz midi in a raspberry

Postby sema » Mon May 08, 2017 8:00 am

Raspberry PI is currently not supported, but that's a great idea for the future development.
sema
Site Admin
 
Posts: 306
Joined: Mon Oct 17, 2011 7:28 pm

Re: Can't start Jazz midi in a raspberry

Postby autotel » Wed May 10, 2017 1:41 am

good to know!
Well, indeed would have been nice for my current project.
thanks for the reply!
autotel
 
Posts: 2
Joined: Fri May 05, 2017 12:28 am


Return to jazz-midi

Who is online

Users browsing this forum: No registered users and 1 guest

cron